
 
 
 
 

 
 
 
 
 

 
 
                                  
 
 

INSTRUCTION MANUAL 
PCE-MSR 145S/ PCE-MSR 145W 

 

                                    

                                          

         

                                                    
 

                                  

                                              
 
 
 

 
 

 
 
    
                              

www.pce-industrial-needs.com

Tursdale Technical Services Ltd  
Unit N12B 
Tursdale Business Park 
Co. Durham 
DH6 5PG 
United Kingdom 
Phone: +44 ( 0 ) 191 377 3398 
Fax:     +44 ( 0 ) 191 377 3357 
info@tursdaletechnicalservices.co.uk  
http://www.industrial-needs.com/ 

 

 



 
 
 

info@tursdaletechnicalservices.co.uk 
 
 

2 

Contents: 
INSTRUCTION MANUAL .................................................................................................... 1 

1.Important notes regarding this user manual. ............................................................... 4 

2.Safety instructions and warnings ................................................................................. 5 

3.Overview .......................................................................................................................... 6 

4.Controls ........................................................................................................................... 7 

5.Turning the unit on / saving measurement parameters .............................................. 7 

6. Maintenance ................................................................................................................... 7 

7.Specifications .................................................................................................................. 9 

8.Operating, transport and storage conditions ............................................................. 12 

9.Troubleshooting ............................................................................................................ 12 

10.Packing list .................................................................................................................. 13 

11.Warranty ....................................................................................................................... 13 

12.Disposal ....................................................................................................................... 13 

13.PC Software ................................................................................................................. 13 
13.1 Overview .................................................................................................................................................. 13 
13.2 Installation of the MSR PC software on a PC ................................................................................. 14 
13.3 Starting the MSR Software .................................................................................................................. 15 
13.4 Uninstalling ............................................................................................................................................. 16 
13.5 System Requirements .......................................................................................................................... 16 
13.6 Preparation .............................................................................................................................................. 16 

14.Setup ............................................................................................................................ 19 
14.1 Basic settings ......................................................................................................................................... 19 
14.2 Prediction ................................................................................................................................................ 19 
14.3 Shock Assistant ..................................................................................................................................... 20 
14.4 Reducing the volume of data ............................................................................................................. 20 
14.5 Conditional recording of measurement parameters (limits) ...................................................... 21 
14.6 Setting the alarm limit .......................................................................................................................... 21 
14.7 LED behaviour ........................................................................................................................................ 22 
14.8 Transferring basic settings to several MSR 145s ......................................................................... 22 
14.9 User settings .......................................................................................................................................... 23 
14.10 Calibrating the analog inputs ........................................................................................................... 24 
14.11 Calibrating the acceleration sensors ............................................................................................. 26 
14.12 Calibrating the humidity and temperature sensors ................................................................... 27 
14.13 Formatting the memory ..................................................................................................................... 28 

15.Reader .......................................................................................................................... 28 



 
 

info@tursdaletechnicalservices.co.uk 
 

 
 

3 

16.Viewer ........................................................................................................................... 29 

17.Online ........................................................................................................................... 35 

18 Utility programs........................................................................................................... 37 
18.1 CSV ........................................................................................................................................................... 37 
18.2 Cutter ........................................................................................................................................................ 38 
18.3 Calc ........................................................................................................................................................... 38 
19.4 Concat ...................................................................................................................................................... 41 

19. Output Manager.......................................................................................................... 43 

20. Additional software for PCs ...................................................................................... 43 
20.1 FreeMat .................................................................................................................................................... 43 

 

 



 
 
 

info@tursdaletechnicalservices.co.uk 
 
 

4 

1. Important notes regarding this user manual. 
In this manual notes of particular importance are presented as follows: 

 
 

 
Indicates  that  equipment  may  suffer  dam- 

WARNING                    age or that there is a risk of injury to the op- 
erator or user should the instructions not be 
followed correctly . 

 
        Indicates  that  equipment  may  suffer  dam 

CAUTION                   age or that data loss may occur should the                
        instructions not be followed correctly. 

 
 
 
 
 

Convention 
Term / Symbol Description Example 
MSR 145 In this manual the term "MSR 145" 

is used to mean both "MSR 145S"
and "MSR 145W"

 

Commands, programs, 
menu items, functions, 
field names 

Commands, programs, menu 
items, functions, field names are 
shown in bold. 

Record 

-> X See page X  
 • Reference to further information 

• Further information 
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2. Safety instructions and warnings 
 

              
 
       
       WARNING 

 
 • Read the operating instructions carefully before using the MSR 145 or the 

MSR software . This will protect you personally and avoid damage to the unit . 
 

• The MSR 145 is a unit for recording and displaying measurement param- eters 
and may not be used for safety-related applications . 

 
• Before using the MSR 145 check the unit itself and all cables for visible signs of 

damage and never operate a damaged MSR 145 . A damaged MSR 145 can 
endanger operator safety! Should the MSR 145 not function perfectly or appear to 
be damaged, send it to MSR Electronics GmbH for repair . 

 
• Ensure that no fluids enter the MSR 145's casing. Fluids cause  corrosion 

damage and short-circuits inside the MSR 145 . 
 

• The MSR 145 must never be opened or modified. The manufacturer cannot be 
held liable for damage resulting from use other than that for which the unit is 
intended, or from improper operation of the unit . 

 
• Never use an MSR 145 with a leaking battery. Should a battery leak be de- 

tected ensure that the electrolyte does not come into contact with the skin, the 
eyes or the mouth . Should this occur, thoroughly rinse the affected area with 
water for at least 15 minutes . Consult a doctor . Do not breathe in any vapours 
emitted . Immediately clean the electrolyte from the MSR 145 using a soft cloth 
and dispose of the cloth subsequently . 

 
    
 
     CAUTION 

 
 
 

• Ensure the proper disposal of an obsolete MSR 145 and USB connection cable . 
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4.Controls  
 

                                         
                                                                                                                             

 
  5.Turning the unit on / saving measurement parameters 
 
 The storage properties of the MSR 145 are determined using the Setup     
  pro- gram*. Control of measurement parameter storage can be either   
  time activated, value activated or by pushing the push button. 
 
*Setup is an MSR PC program. 

 
 
 
 
 
 
 
 
 
 
 

 6. Maintenance 
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User checks 
• Check the MSR 145 before each use. 
• Before using the MSR 145 check for visible signs of damage. 
• Check the functions of the MSR 145. 
• Never use an MSR 145 that is damaged or not functioning perfectly.Never   
   use damaged accessories . 
• Ensure that the battery is sufficiently charged for the required period of   
  use. 
Should the MSR 145 not function perfectly or should damage become apparent 
send the unit to MSR Electronics GmbH for repair . Repairs may only be carried out 
by MSR Electronics GmbH or an authorised dealer. Defective or damaged 
components may only be replaced with manufacturer’s original parts . 

 
 

 
Cleaning 

 
  • MSR 145S:  Ensure  that  no  fluids   

  CAUTION                  enter  the  MSR 145's casing. Fluids   
  will cause corrosion  damage and short   
  circuits.                                 

• Never use corrosive or abrasive cleaning agents or polishes. 
• Cleaning agents containing additives such as alcohol will cause the case to   
become matt and/or brittle . 

 
 
 

• Clean the MSR 145 when necessary. 
• Always disconnect the MSR 145 from the PC before cleaning. 
• Use a cleaning agent suitable for plastic or a cloth dampened with water and soap. 

 
Charging the battery 
Before first use: The battery is not fully charged on delivery and should 

be  charged  for  approx .  3  hours  before  using  the 
MSR 145 for the first time . 
 

Charge the MSR 145: • Before each use 
         • At least every six months 

Method: 
• Connect the MSR 145 and the PC using the USB connection cable. 

 
Notes: 
• Ensure that the PC remains switched on. 
• The yellow LED illuminates during charging (continuously). 
• Charging is completed after a maximum of 3 hours. 
• Recorded data is non-volatile and remains in the unit’s memory even when 

the battery is exhausted . 
• Never store the MSR 145 with a discharged battery. 

Meaning of the yellow lamp when a USB device is connected 
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 Yellow LED Meaning 

 Lights continuously Charging in progress 

   ○ Off Fully charged or no connection to 
PC or PC turned off 

 Flashes Fully charged 
 
The battery is recharged for a 
short time, e .g . during an online 
measurement or data recording 

 
 
 
 
 

7.Specifications 
 
Measured parameters: • Temperature 

• Relative humidity with integrated Temperature 
• Pressure (e .g . altimeter, water level, barometer) 
• 3-axis acceleration (e.g. determining position) 
• 2 analog inputs (voltage range 0 to 3 .0 V, 12 bit) 

 
Working range: 
Temperature: -10 °C to +58 °C 

-55 °C to +125 °C (optional with external sensor) Humidity:
 0-100 % relative Humidity, -20 °C to +65 °C Pressure: 0-
2500 mbar absolute 

Optional: 0-14 000 mbar absolute 
Acceleration: ±10 G / ±2 G selectable 

 
Accuracy: 
Temperature: ±0,1 °C (5 °C to 45 °C) 

±0,2 °C (-10 °C to +58 °C) Options with 
external sensor: 
±0,1 °C (5 °C to 45 °C) 
±0,5 °C (0 °C to +70 °C) 
±2 °C (-55 °C to +125 °C) 

 
 
 
Humidity: ±2 % rel . humidity (10-85 % rel . humidity, 0 to 40 °C) 

±4 % rel . humidity (85-95 % rel . humidity, 0 °C to 40 °C) 



 
 
 

info@tursdaletechnicalservices.co.uk 
 
 

10 

±0,5 °C (0 °C to 40 °C) 
Pressure: ±2,5 mbar (750-1100 mbar absolute) 
 
Acceleration: ±0,15 g (25 °C)
Storage rate: Temperatur and humidity: 1/s to every 12 h 
 Pressure: 10/s to every 12 h 
 Acceleration, Analog input:  50 /s to every 12 h 

 
Memory capacity: Over 2 000 000 measurement parameters 

 
Push-button: Set bookmark or start and stop the record 

 
General MSR 145S MSR 145W
Size (mm): 20 x 15 x 52 18 x 14 x
Weight approx.: 16 g 18 g
Sheath material: PC Silicon 
Medium: Air Air, water

 
 
 
Power supply: 

               • Rechargeable lithium polymer battery 170 mAh 
               • The battery is charged via the USB connection. 
                           • One battery charge is sufficient for operation of the unit   
                      for several months (measurement rate 1 / minute) 
      
Interface:  USB     
connection cable:   Approx . 200 cm     
Standards: The MSR 145 complies with EU Directive RoHS / 

WEEE . 
MSR 145S: Protection Classification IP 60 
MSR 145W: Protection Classification IP 67 

 
 



 
 

info@tursdaletechnicalservices.co.uk 
 

 
 

11 
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8.Operating, transport and storage conditions  
 
• Protect the MSR 145 from excessive exposure to the sun and other sources of heat 
. Avoid heavy impacts . 
• Do not place heavy objects on top of the MSR 145. 
• Only store the MSR 145 in a dry, dust-free environment. 

 
Operating conditions: 
Temperature: -20°C to +65 °C 
Pressure: 500 mbar to 2500 mbar absolute 

 
 
 
Optimal storage and transportation conditions: 

 
Temperature: 0°C to 45°C (ideal storage condition for the battery) 
Humidity: 10-95% relative humidity, non-condensing 
Battery charge level: Never store the MSR 145 with a discharged battery. The ideal 

charge level is a 2/3 charge (a discharged battery achieves 
this charge level after approx. 2 hours’ charging) . 

• MSR 145S: Avoid contact with water and humidity. 
 
• MSR 145W: Relative humidity: 30% to 95% max. 

(storage and transport 10-95%) 
 

9.Troubleshooting 
 

Problem Possible cause Possible solution 

 
The temperature increases 
con- tinuously when the 
MSR 145 is con- nected to 
the PC 

The battery warms 
Up because charging 
commences when the 
MSR 145 is connected
to the PC . 

 
When making temperature 
measurements disconnect 
the MSR 145 from the PC. 

 
The MSR PC programs do 
not recognise the con- 
nected MSR 12 

 
The COM port driver 
is not installed 
correctly. 

 
Observe the manufactur-
er’s installation instructions 
http://www .ftdichip .com/ 
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10.Packing list 
• MSR145S or MSR145W 
• CD including: 
• User manual 
• MSR PC software 
• MSR145 USB connection cable 
• Warranty card 

   Options:   • Additional sensors 
 • Adapter for connecting further sensors 

 
 

11.Warranty  
 
See warranty card . 
 
 

12.Disposal 
 

Take the MSR 145 to a municipal waste disposal centre or return it to MSR 
Electronics GmbH . The MSR 145 must not be disposed of in normal domestic 
waste . 
 

 
 

 

13.PC Software 

13.1 Overview  
 
External processing of MSR 145 data is carried out using the MSR PC software 
programs Setup, Reader, Viewer and Online . The MSR PC programs can be used 
for all MSR types . 
The Setup enables the properties of the MSR 145 to be customised to user’s 
requirements . 
The Reader allows the user to transfer measurement parameters to a Windows 
PC . The Viewer is used to display data graphically or in table form or to export it as a 
text file (* .csv) . 
With the help of Online users can view measurement parameters and curves “live” on 
a PC . 
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13.3 Starting the MSR Software 
The MSR software may be started by clicking on the MSR symbol  or via 
Start > Programs > MSR > MSR 
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13.4 Uninstalling  
 
The software is uninstalled via the computer’s operating system (Programs > MSR 
> Uninstall MSR) . 
 
 

13.5 System Requirements  
 
• Windows 95 or higher 
• USB port 

 
 

13.6 Preparation  
 
Before using the MSR PC programs Setup, Reader and Online, the following 
preparations must be completed: 

 

• Use the USB connecting cable to connect the MSR 145 with the PC. 
• Before first use: Using  open the MSR program window, select Settings> MSR 
. 
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The template, selected via Setting > MSR (* .mse), defines which sen- sors 
the Reader reads out as standard or are displayed in Online . The template 
sets the colour of the trace, the positioning of its axis (left, right) and gives the 
sensors a name (“HUM, T1” is required to be displayed as 
“outside temperature”, for example) . Templates can be produced on the basis 
of examples contained in Viewer. 
 
Example 
The temperature curves are required to be blue and oriented on the right hand 
axis in all display modes . 
 
1 . Assign right hand axis and blue colour shades to temperature in Viewer . 
2 . Save as template (Bluetemp .mse) . 
3 . Generate  new  templates  for  Reader  and  Online:  Select  MSR  pro- 
gram window, Settings MSR > Template, enter new name and path 
(Temperature .mse), then Open . 
4 . Open the still blank template (Temperature .mse) using. 
5 . Import  the  template  that  was  created  in  Viewer  (Bluetemp .mse). 
Select the required sensors (tick in checkbox) in the Module column and  
6 . Edit the displayed list: First select a sensor in the Module column and then 
choose Edit . 
7 . Change the name “HUM, T1” to “Outside temperature”,  
and Accept . 
8 . Continue to make the necessary adjustments and confirm them with Accept . 
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Pre-adjustments - Reader 
 

Enter the required options for the Reader** via Settings > Reader. 
 
**Data records are transferred from the MSR 145 to a PC using the Reader. 
 
Once data transfer is complete the Reader creates a data record (* .msr) from each 
logged record, names it and saves it in the corresponding directory . The bottom-
most option allows the user to alter the suggested filename and location . 

             
 
 
Once  the  data  has  been  transferred  to  the  PC various  options  are  available  to  
the  user .  Details may be found in the text window . 

 
Example: "Automatically generate a text file" In  addition  to  the  MSR  format  
file,  the  Reader creates  a  text  file  (* .csv),  which  can  be  opened with  
programs  such  as  e .g .  Microsoft  Word  or Excel . 

 
Pre-adjustments - Online 

 
The  functions  described  on  this  page  are  currently  not  available  with  the MSR 
145 . 
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Completion of the preparatory measures 
 
Upon exiting Settings the PC saves the settings that were last entered . The 
default settings can be reinstated by selecting Settings > MSR > Default. 

 
Once entry of the settings is complete, select Programs and start the required 
program. 

 
Note:   The  following  instructions  assume  that  the  preparations  for  using  the 
MSR PC programs have been completed. 

 
 

14.Setup  
Setup is used to select the sensors for which the MSR 145 is required to save 
measurement parameters, to enter the measurement frequency and to set the 
behaviour of the MSR’s memory . In Setup you can also define the start time for data 
recording and stop data recording . 
 
The following subjects are dealt with in the Setup chapter: 
 

14.1 Basic settings  
 
Note:   This page describes the most commonly used settings – the Basic set- tings 

. Information on further settings can be found on the following pages. 
 
•   Complete the preparations . 
•   Start Setup (Setup symbol). 
•   Under Read basic settings, read the configuration saved in the MSR 145. 
•   Edit the Basic settings according to your requirements . 
•   Transfer the new configuration and the start conditions to the MSR 145 with Write 
basic settings. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

14.2 Prediction 
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The  maximum  amount  of  data  that  can  be recorded is influenced by: 
• The number of sensors 
• The measurement rate 
• The battery capacity 
 
With each click on Prediction (Basic settings) the program generates an ap- 
proximate prediction using the selected basic settings. 

 
Note: The Limit settings are not taken into account here. 

 
 

14.3 Shock Assistant 
 

 
 
 
 
 
  

  Using  the  Shock  assistant  you  can  rapidly configure  the  MSR  145  for  a     
  shock  meas- urement (conditional recording of accelera- tions) . 
  Menu access via Basic settings> Shock assistant . 
 
Only those acceleration values are recorded that exceed the value set for the 
threshold limit. Acceleration due to gravity over and above the measurement is not 
taken into account. 
The figure input for the threshold value is set as the limit for the X, Y and Z axes of 
the accelerometer . The accelerometer and limits are activated, 50Hz is used as the 
measurement rate. 

 
Note: Other settings are not affected. 
 

 
 
 
 
 
 

14.4 Reducing the volume of data  
When making extensive recordings it is recommended that all sensors that are not 
required be “turned off”. This prevents unrequired measurement param- eters from 
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being saved . 
 
•   Under Basic settings turn "off" all unused sensor groups (see next sec- tion) . 
•  To turn off individual sensors within one sensor group proceed as follows: Set 

the cut-in condition such that they are not activated during the planned recording 
(e .g . > 200 °C) (see next section) . 

 
 
 

14.5 Conditional recording of measurement parameters (limits) 
 
If for example, you require only to record temperatures above 5°C and less than 20 
°C, use the following procedure 
 

         
 
 

 

14.6 Setting the alarm limit 
 
The MSR 145 can display an alarm if a certain measurement parameter drops 
below or exceeds a certain value . When the alarm condition occurs the red LED 
flashes once per second until the data recording is stopped or the alarm function is 
exited. 
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Inputting the alarm condition is carried out in the same way as setting the cut-in 
conditions (see section Conditional re- cording of measurement parameters) . In 
the Alarm Limit, Limit L1 and Limit L2 columns enter the alarm conditions . The 
alarm limits can be displayed in Viewer. 
 

 

14.7 LED behaviour 
 
The behaviour of the blue LED is defined via Setup > Basic settings . 
 
 
 
 
 
Situation                                            Behaviour of the blue LED 

   
  Start time has  been  First 5 seconds Double-flashes 5 times at 1-second                       
  transferred to the                                intervals 

  MSR 145(nonfuzzy)   Warten auf       Double-flashes at 5-second intervals 
                                   Start (scharf) 
 

   
   Datenaufzeichnung  First 5 seconds  Flashes 5 times at 1-second intervals 

läuft 
                                          After 5 seconds LED flashes with main LED does not  
                                                           storage rate t1              flash 
 
 
 

14.8 Transferring basic settings to several MSR 145s 
 
Use the following procedure to transfer basic settings that have already been 
input to several MSR 145s: 

 
•   Start Setup. 
•   Connect the MSR 145 to the PC. (If several MSR 145s are connected to 

 the PC, select the COM port of the required MSR 145). 
•   Enter the required values in the Basic settings tab. 
•   Set the cut-in and alarm conditions in the Limits tab. 
•   Use Write basic settings to transfer the basic settings to the MSR 145. 
•   Disconnect the MSR 145 just configured and connect the next MSR 145    
     to the PC. 
•   Select the new MSR 145 via COM Port. 
•   Caution! If you wish to import the information and measurement para- 

 meters of the newly connected MSR 145, you must first select the option Freeze, 
so that the settings in the Basic settings and Limits tabs are not overwritten! 

•   Transfer the basic settings to the MSR 145 with Write basic settings 
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Note:   It is also possible to configure differently equipped MSR 145s with a single 

basic setting . One MSR 145 may for example, not be equipped with any 
analogue inputs . The setup program then simply does not write any data to 
the settings saved in the MSR 145 for those analogue inputs . 

 
•   If a connected MSR deviates too greatly 

from the first MSR, this message appears:  
 
 
 
 

 
 
 
 

14.9 User settings  
 
To display the configuration saved in the MSR 145 select the Basic settings tab1 
and click Read basic settings. The settings are now displayed in the User settings 
tab. 
 

                                                  The changes made in the User settings tab         
                        CAUTION           and  its sub-menus  will  only  be ransferred                                      

                               to the MSR 145 after clicking Write user             
                               settings 2. 
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Note:   The   fields   available   for   input   are   dependent   upon   the   respective 
MSR 145. 
 
 
 

14.10 Calibrating the analog inputs 
 

The analogue digital converter (ADC) of the MSR 145 converts an external volt- 
age U between 0 .0 V to 3 .1 V into an internal digital signal D between 0 and 4095 
. This signal D is converted to the value displayed A using the linear equation A = 
m*D+n . Here m represents the gain and n the offset (zero point). 
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Two options are available for calibration: 
 
a) For the high and low point the required target values 1 and the corresponding ADC 
values 2 are entered manually . Then the offset (zero point) and the gain 4 are 
automatically calculated by clicking on Calculate 3. 
 
b) For the high and low point the required target values 1 are entered manu- ally . 

Then the voltages applied to the MSR 145 for the high and low points are 
measured by clicking on Measure 5 . Clicking now on Calculate 3 allows the 
offset (zero point) and the gain 4 to be calculated. 

 

                             
 
 
 
The appearance of the displayed value is set by entering the target unit and format 6 
(number of decimal places). 

 
• Complete calibration by clicking OK 7 . 
• Transfer the new calibration settings to the MSR 145 by clicking on Write 

user settings. 
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14.11 Calibrating the acceleration sensors 
 
Depending upon requirements, the acceleration sensors may either be manu- ally 
calibrated or the Factory settings may be activated from the User set- tings tab . 
Transfer the new calibration settings to the MSR 145 using Write user settings . 

 
 
        
  
 
Resetting calibration to factory settings 
• Select the User settings tab and click on Factory settings. 
• Transfer the factory settings to the MSR 145 with Write user settings. 

 
Manual calibration 
• Select the User settings tab and click Calibrate. Click on Help to display the 
Position of the axes. 
 

                            
 
• Select the 2 G measure range . 
• Hold the MSR 145 so that the + X axis is oriented vertically - bottom-to-top. 
• Click on measure 1 . 
• Turn the MSR 145 over. Now the -X axis is oriented vertically - bottom-to- 

top . 
• Click on measure 2 . 
• Repeat the procedure for the +Y, -Y, +Z and -Z axes. 
• Select the 10 G measure range . 
• Hold the MSR 145 so that the + X axis is oriented vertically - bottom-to-top. 
• Click on measure 3 . 
• Repeat the procedure correspondingly for the +X, +Y, -Y, +Z and -Z axes. 
• Complete calibration by clicking OK . 
• Transfer the new calibration to the MSR 145 with Write user settings . 
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14.12 Calibrating the humidity and temperature sensors 
 
For humidity and temperature the two point calibration procedure can be carried out . 

 
Preparation 
Before measurement of the actual values is carried out any existing two point 
calibration should be removed: 

 
1 . Check Change values 1 
2 . Deactivate the parameters to be calibrated 2 (inactive) 
3 . Transfer these settings to the MSR 145 via Write user settings. Now the 

current measurement parameters may be used as actual values . 
 
Carrying out calibration 
1 . Check Change values 1 
2 . Activate the parameters to be calibrated 2 
3 . Enter the target 3 and actual values 4 for both points . 
4 . Transfer these settings to the MSR 145 via Write user settings . 
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14.13 Formatting the memory 
 

             
            Formatting will erase all measurement pa-

CAUTION             rameters saved in the MSR 145! 
 
 
 
Formatting  is  used  to  delete  all  the  measurement  parameters  saved  in  the 
MSR 145 . 

 
Formatting the MSR 145 is carried out from the Format memory tab. 

 
                        

 
 
 

15.Reader 
 
With the Reader users can selectively transfer data records logged with the MSR 
145 to a PC . It does however free measurement records that have al- ready been 
read out for overwriting . 

 
Transferring data records to a PC 
• Complete the preparations. 
• Start the Reader (Reader symbol) 

 
                                                             
                                                                            
                                                                    Once data transfer has started (Start) all data 
                          CAUTION               records saved on the MSR 145 can be    
                                                          overwritten if required, even if the circular buffer   
                                                          is deactivated in Setup. 
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• Begin data transfer with Start . 
The options selected under Settings > Reader influence the next steps: 
• Under the option Read selected records the following data entry dialog box 

appears: 

                  
 
 
 
With   the   option   Read   selected   records   and   save   with   “Save   dia- log  
as”  under  Settings  >  Reader  the  filenames  and  locations suggested  
by Reader can be overwritten . 

 
Once  the  data  records  have  been  saved  on  the  PC  a  list  of  files  created 
appears . 

                           

 
 
 

16.Viewer 
 
Records created in Reader or Online may be viewed and edited on a PC with the 
Viewer . The measurement parameters may be displayed either in graph 
or in table form . 

 
• Start the Viewer (Viewer symbol) . 
• Open a record (*.msr) via File > Open . 
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Move traces With right mouse button held down . 

 
Enlarge section Mark the required section with the left mouse button 

held down . See also Graphics > Fixed axis . 
 
Cross-hair Move axis: Grab the axis, move with left mouse button . 
 Move centre: Grab the centre, move with left mouse button .
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                               Table(Tabelle) 
                                     Go to time allows users to jump straight to the line in the table   
                            with the required time . 
 
                                     Jump to beginning of graph causes the table to jump   
                                     to the first measurement values displayed in the graph . 
 

 Table(Tabelle) 
                                     Go to time allows users to jump straight to the line in the  
                                     table  with the required time . 
 

Jump to beginning of graph causes the table to jump to the 
first measurement values displayed in the graph . 
 

     Configuration 
                                     As long as the Configuration  dialog is not quitted, Undo   
                                     allows the last changes made to the configuration screen to be  
                                     undone . 
 

       Text mode 
Using  the  text  mode  you  can  insert  texts  at  any place . 
By clicking on you can activate and deactivate the text mode . 
 

 
                                     Insert text: 

• Click  on    .  The  viewer  displays "Text 1" in   
   the upper left corner. 
• Drag  the  text  field  to  the  desired place . 
• Double  click  on  the  text  field  and enter your  
  required text . 

 
• Click  with  the  right  mouse  button on the 
text field and select Delete . 

 
 

                           Delete text: 
                                                Text field with X and Y values: 

• place the crosshairs on    
  Your chosen position to    
   adoddopt the X and Y values  
   you would like to use in the   
   text field. 
• Create a text field (see above)  
   And click on the right mouse  
   button. Select the desired  
   representation. 
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CAUTION 
 
 

     Depiction of the curves using dots (Configuration>Curves >       
     Dot:  Yes)  requires  more computing power, possibly leading   
     to problems. 

 
 
 
 
 

 Using Configuration>Time axis X, the time axis can be 
annotated, the time segment to be displayed can be set, and 
the Increment for the lettering and 
ruled lines, together with the Format for numbers can be 
entered .Automatic axis annotation with an Increment of 0 
(zero) . 

 
Undo the last changes 
 
The number Format for the displayed X and Y val- ues is entered via 
Configuration>Crosshairs.The displayed  Y  value  always  relates  to  the  left axis. 
 
Quit Configura- tion 
 
As long as Configuration is not quitted, users can undo the last changes made to 
the displayed con- figuration screen with  . 
 
Quit Configuration via Graph or Table. Upon quitting, the Viewer saves the 
configuration . 
 
 
 
 
 
 

Configuration allows the display method of the measurement 
parameters to be set with the help of the configuration screens 

Entering title and footer information is achieved via 
Configuration > General 
 
The  associated  sensor  name,  assignment  to  
the left  or  right  axis,  the  colour,  line  weight  and  
style can be set for each curve . 
 
Axis > inactive allows the graph curve to be shown 
or hidden as required . 
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17.Online 
Online  allows  users  to  view  the  progress  of  the  measurement  parameters 
directly on-screen . 

 
Procedure: 
• Complete the preparations . 
• Start Online (Online symbol) . 

 
 

                                           
 
 

• Select the sensors that you wish to display . 
• Click on Next . 
 
 
• Online displays the measurement parameters graphically and numerically. 
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For  recurring  applications  in  Online,  Templates  assist  in 
selecting the required sensors and adjusting the display to suit. 
 
Create template: Start Online and select the required sen- sors . 
Select Next> . Use 
Graph > Properties, Graph > Grid line, Graph > Legend and 
Graph > Start time to change the way the curve is dis- 
played . Via Back return to the trace display . Interrupt re- 
cording  with  Stop .  Save  the  template  via  File  >  Save  as 
template . 
 
Apply the template to Online: File > Use template and se- lect 
the required template (*mse) . 
 
Once  recording  has  finished  by  clicking  on  Stop,  the  re- 
corded measurement parameters can be saved via File > 
Save as . 

 
In the menu View the measurement parameters can be dis- 
played as curves with Graph or as numerical values with 
Monitor . The font displayed on the monitor can be selected via 
the menu Monitor > Font . 
 

Once  recording has finished by clicking  on  
Stop,  the  re- corded measurement parameters 
and traces can be delet- ed via Clear . 

 
The  display  can  be  changed  via  Properties,  
Gridlines, Legend and Start time . 

 
Select the frequency (Refresh rate) with which 
measure- ment parameters are to be transferred to 
the PC . 
 

In the Time window you can define the time period 
represented by the time axis . 
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18 Utility programs 
 

18.1 CSV 
 

The CSV utility creates text files (* .csv or *  .fmc) from data records (* .msr) . Files 
saved in * .csv format can subsequently be opened and edited in a word 
processing or spreadsheet application . The * .fmc files can be transferred to 
FreeMat1 . 

 
Creating a text file 
• Start CSV (MSR Program window > Tools > Csv) . 

 

 
 
 

• Select  the  output  format  (standard  *.csv  or  Free- Mat *  .fmc) 
 
• Click on Start and select the data record from which the text file is to be created .  
CSV creates a text file(* .csv) and saves it in the corresponding directory for that data 
record . Text file (* .csv) and data record(* .msr) have the same name . 
Note on creating *.csv files: If a template (*.mse) exists for the data record in 
question, CSV takes this into account when creating the text file (* .csv) . 

 
Example: Opening a CSV text file with Excel 
• Start the word-processing or spreadsheet program. 
• Open the CSV file via File > Open . 
• Under File type, select Text Files . 
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Further details on FreeMat can be found in the section FreeMat  
 
 
 
 

18.2 Cutter 
The Cutter utility creates an extract from a data record (* .msr) . 

 
Creating an extract from a data record 
• Start the Cutter utility (MSR Program window > Tool > Cutter) . 

 
• Click  on  Start  and  select  the  data  record  from which the 
extract is to be created . 

 
• Select the time window. Beginning / End . 

 
• Select  the  sensors  for  which  the  measurement 
parameters  are  to  be  exported  to  a  new  data record 
and click Next . 

 
• Enter  the  name  and  directory  for  the  new  data 
record . Click on Save . 

 
 
 

18.3 Calc 
 
With Calc curves from existing data records can be linked to each other using 
formulae and saved as a data record (* .msr) . The saved data record can be 
displayed and processed in the form of curves or as a table using the Viewer . 
Templates simplify the processing of recurring tasks . 
Note: For making comprehensive calculations the FreeMat math software is 
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Note: The curves are saved as data records (*.mrs). The saved 

measurement parameters can be displayed and processed as a curve 
or as a table by the Viewer . Intermediate values are interpolated . Only 
curves that overlap timewise can be calculated . 

 
Creating a template for processing recurring tasks 
Once you have created the new curves you can save their labels  and  
formulae  as  a  template  (* .mse) .  (Template  > Write) . 

 
Creating new curves using templates 
Open the required template (*mse) via Template > Read . This will 
automatically generate a number of new curves . Multiple templates may 
be used to generate new curves . Each template generates a number of 
new curves . 

 
 
Operators / brackets 
+  -  *  /   ^ Plus, minus, multiply, divide, to the power of 
(  ) Open brackets, close brackets 

 
 
Functions 
sqrt(no .) Square root of the number 
ln(no .) Natural logarithm of the number (base e) 

 
exp(no .) Raise basis e to the power of the number 

 
abs(no .) Absolute value of the number sgn(no .) no . 
>0: sgn = 1 

no . =0: sgn = 0 
no . <0: sgn = -1 
 

cos(no .) Cosine of the number sin(no .) Sine of 
the number tan(no .) Tangent of the number 
ctg(no .) Cotangent of the number 

 
arcsin(no .) Arc sine of the number arccos(no .) Arc 
cosine of the number arctan(no .) Arc tangent of the 
number arcctan(no .) Arc cotangent of the number 

 
sinh(no .) Hyperbolic sine of the number cosh(no .)
 Hyperbolic cosine of the number tangh(no .)
 Hyperbolic tangent of the number ctgh(no .)
 Hyperbolic cotangent of the number 

 
toggleSgn(no .) Changes every second measurement parameter sign 

(plus/minus) 
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Further functions on request 

19.4 Concat 
 
With Concat (concatenate = to link) data records can be linked together and saved 
as a new data record (* .msr) . The newly created data record can be dis- played and 
processed in the form of curves or as a table using the Viewer. 
 

                       
Concatenating several data records 
Start Concat (MSR program window > Tools > Concat) 

 

               
 
 
 

1 Select the data records to be concatenated 
Open  the  data  records  that  you  want  to  concatenate  by  clicking  Add . Note 
that the list must be in chronological order such that the oldest data record is at 
the top . Therefore either open the oldest data record first or sort the list 
afterwards (see below) . 
 
Sort the list alphabetically 
Use Sort to sort the list alphabetically . Data records that have automatically 
generated filenames (->33) can be chronologically sorted using Sort . 

 
Modify the data record order 
With the left mouse button pressed, drag the number field to the required position 
. 
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3 Calculating the new data record 
Start  the  calculation  process  with  Start . 
Cancel  the  calculation  with Stop . 
 
Note: 

• Concat  creates  a  straight  line  between  the  
   last data  record  of  the  first  curve  (T1)  and  
   the  first data record of the second curve (T2) 
 
• If, for the data records to be concatenated,  
  there are curves that overlap timewise and  
  these have he same name (same module and 
   sensor names with the same units), the  
  calculation will be aborted and a  
  corresponding message* will appear in the  
  status window. 
 
• If the module names, sensor names or units  
  of the curves to be concatenated  do not  
  correspond Concat  will  be  unable  to  join   
   the curves and will create two curves .** 
 
• With Concat you can superimpose  curves   
  with different module or sensor names . 
 
* Remove overlap 

Use  the  Cut  utility  to  create  an  excerpt 
from  a data record that does not overlap
timewise with the next data record . 
 

* Modify module names, sensor names and    
unitsUse the Calc utility to match the module 
names, sensor names and units 
for the curves . 
 

 
 

Delete all data records from the list 
Use Delete all to remove all data records from the list . 

 
Delete one data record from the list 
Select the data record to be deleted and click Delete line . 

 
 
2 Enter the name and directory for the new data record 

Set the path to the directory using Browse and enter the filename, or use the input 
window to do this . 
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19. Output Manager 
The Output Manager is currently not available . 

 

                                                       
 
 
 
 

 
20. Additional software for PCs 
 

20.1 FreeMat 
 
FreeMat is open source math software that can be installed from the MSR CD 
(ADDITIONAL\FREEMAT). FreeMat can be used to carry out a wide variety of 
calculations . 

 
How are data records transferred to FreeMat? 
The Reader transfers the data recorded with the MSR 145 
(records) to the PC . From these data records (* .msr) CSV creates FreeMat 
files  (* .fmc) .  Using  the  scripts  included  these  can  be  opened  and  edited  in 
FreeMat . 

 
More information on FreeMat can be found at 
http://freemat .sourceforge .net/index .html . 
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The following FreeMat scripts can be found on the MSRCD under ADDITIO- 
NAL\FREEMAT\MSCRIPTS: 

 
plotmsr .m Imports  * .fmc  files  into  the  FreeMat  environment  and 

presents the data records graphically . 
 
loadmsr .m Imports * .fmc files into the FreeMat environment . 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
In this direction will find a vision of the measurement technique: 
http://www.industrial-needs.com/measuring-instruments.htm 
  
 
NOTE: "This instrument doesn’t have ATEX protection, so it should not be used in potentially explosive 
atmospheres (powder, flammable gases)."    


